Follow

What devices does Moov Now™ or Moov Classic™ support?

Currently supported iOS (8.0 or higher) devices:

  • iPhone 5, 5S, 5C, 6, 6 Plus, 7
  • iPod Touch (5th gen or newer)
  • iPad 3, 4
  • iPad Air, Air 2
  • iPad Mini (All generations)

Moov supports most Android devices which have:

  • Android 4.4.4+ (for the new all-in-one Moov app)
  • Bluetooth 4.0 with BLE

Moov uses Bluetooth Low Energy (BLE) to sync with your Android device. Bluetooth Low Energy is also referred to as “Bluetooth LE”, “BLE”, “Bluetooth Smart”, or “Bluetooth Smart Ready”. Consult the manufacturer’s spec sheet for your device to see if BLE is supported. Bluetooth Low Energy comes with some, but not all devices equipped with Bluetooth 4.0. If your phone doesn't have Bluetooth 4.0, it does not support Bluetooth Low Energy.

For any more questions and a list of devices with known issues, please see our FAQ on compatible devices here.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.